// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)\b\w*동\b").unwrap();
let string = "대전광역시 서구 탄방동 홈플러스\",\"대전광역시 동 구 효동 주민센터\",\"대전광역시 대덕구 오정동 한남마트\",\"대전광역시 동구 자양동 87-3번지 성동경로당\",\"대전광역시 유성구 용계로 128";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}