package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\w*동\b`)
var str = `대전광역시 서구 탄방동 홈플러스","대전광역시 동구 효동 주민센터","대전광역시 대덕구 오 정동 한남마트","대전광역시 동구 자양동 87-3번지 성동경로당","대전광역시 유성구 용계로 128`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}