re = /\b\w*동\b/
str = '대전광역시 서구 탄방동 홈플러스","대전광역시 동구 효동 주민센터","대전광역시 대덕구 오정동 한남마트","대전광역시 동구 자양동 87-3번지 성동경로당","대전광 역시 유성구 용계로 128'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end