package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)^Snapshot(Name|UUID)[^=]*="v1"$`)
var str = `SnapshotName="v1"
SnapshotUUID="7d1fcb87-69dd-4d14-ba3e-332e94614510"
CurrentSnapshotName="v1"
CurrentSnapshotUUID="7d1fcb87-69dd-4d14-ba3e-332e94614510"
CurrentSnapshotNode="SnapshotName"
SnapshotName="v1"
SnapshotUUID="e5d2bd69-ffc9-45c4-a295-41490708b9c9"
CurrentSnapshotName="v1"
CurrentSnapshotUUID="e5d2bd69-ffc9-45c4-a295-41490708b9c9"
CurrentSnapshotNode="SnapshotName"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}