use strict;
my $str = 'SnapshotName="v1"
SnapshotUUID="7d1fcb87-69dd-4d14-ba3e-332e94614510"
CurrentSnapshotName="v1"
CurrentSnapshotUUID="7d1fcb87-69dd-4d14-ba3e-332e94614510"
CurrentSnapshotNode="SnapshotName"
SnapshotName="v1"
SnapshotUUID="e5d2bd69-ffc9-45c4-a295-41490708b9c9"
CurrentSnapshotName="v1"
CurrentSnapshotUUID="e5d2bd69-ffc9-45c4-a295-41490708b9c9"
CurrentSnapshotNode="SnapshotName"';
my $regex = qr/(?m)^Snapshot(Name|UUID)[^=]*="v1"$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}