// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?m)^Snapshot(Name|UUID)[^=]*="v1"$"#).unwrap();
let string = "SnapshotName=\"v1\"
SnapshotUUID=\"7d1fcb87-69dd-4d14-ba3e-332e94614510\"
CurrentSnapshotName=\"v1\"
CurrentSnapshotUUID=\"7d1fcb87-69dd-4d14-ba3e-332e94614510\"
CurrentSnapshotNode=\"SnapshotName\"
SnapshotName=\"v1\"
SnapshotUUID=\"e5d2bd69-ffc9-45c4-a295-41490708b9c9\"
CurrentSnapshotName=\"v1\"
CurrentSnapshotUUID=\"e5d2bd69-ffc9-45c4-a295-41490708b9c9\"
CurrentSnapshotNode=\"SnapshotName\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}