import Foundation
let pattern = #"(?m)^Snapshot(Name|UUID)[^=]*="v1"$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SnapshotName="v1"
SnapshotUUID="7d1fcb87-69dd-4d14-ba3e-332e94614510"
CurrentSnapshotName="v1"
CurrentSnapshotUUID="7d1fcb87-69dd-4d14-ba3e-332e94614510"
CurrentSnapshotNode="SnapshotName"
SnapshotName="v1"
SnapshotUUID="e5d2bd69-ffc9-45c4-a295-41490708b9c9"
CurrentSnapshotName="v1"
CurrentSnapshotUUID="e5d2bd69-ffc9-45c4-a295-41490708b9c9"
CurrentSnapshotNode="SnapshotName"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)