$re = '/(?m)^Snapshot(Name|UUID)[^=]*="v1"$/m';
$str = 'SnapshotName="v1"
SnapshotUUID="7d1fcb87-69dd-4d14-ba3e-332e94614510"
CurrentSnapshotName="v1"
CurrentSnapshotUUID="7d1fcb87-69dd-4d14-ba3e-332e94614510"
CurrentSnapshotNode="SnapshotName"
SnapshotName="v1"
SnapshotUUID="e5d2bd69-ffc9-45c4-a295-41490708b9c9"
CurrentSnapshotName="v1"
CurrentSnapshotUUID="e5d2bd69-ffc9-45c4-a295-41490708b9c9"
CurrentSnapshotNode="SnapshotName"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);