import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([A-Za-z]+)\\b.*?\\s(\\d+(?:\\.\\d+)?)(?!\\S)";
final String string = "Fluid 13.4\n"
+ "Fluid 13.4 gm% fluid_haemo 12.0-14.0\n"
+ "Fluid gm% 13.4 fluid_haemo 12.0-14.0\n"
+ "Fluid gm% fluid_hameo 12.0-14.0 13.4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}