re = /\b([A-Za-z]+)\b.*?\s(\d+(?:\.\d+)?)(?!\S)/m
str = 'Fluid 13.4
Fluid 13.4 gm% fluid_haemo 12.0-14.0
Fluid gm% 13.4 fluid_haemo 12.0-14.0
Fluid gm% fluid_hameo 12.0-14.0 13.4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end