use strict;
my $str = 'Fluid 13.4
Fluid 13.4 gm% fluid_haemo 12.0-14.0
Fluid gm% 13.4 fluid_haemo 12.0-14.0
Fluid gm% fluid_hameo 12.0-14.0 13.4';
my $regex = qr/\b([A-Za-z]+)\b.*?\s(\d+(?:\.\d+)?)(?!\S)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}