const regex = new RegExp('\\b([A-Za-z]+)\\b.*?\\s(\\d+(?:\\.\\d+)?)(?!\\S)', 'gm')
const str = `Fluid 13.4
Fluid 13.4 gm% fluid_haemo 12.0-14.0
Fluid gm% 13.4 fluid_haemo 12.0-14.0
Fluid gm% fluid_hameo 12.0-14.0 13.4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}