package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\d+).*(?:called|that are like|known like|whose name is|which is called)\s*((?:\w+\s*)+)\s*\??`)
var str = `one of 2 which is called Gundam Test?
Tell me the top 8 animes that are like Gundam`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}