const regex = /\b(\d+).*(?:called|that are like|known like|whose name is|which is called)\s*((?:\w+\s*)+)\s*\??/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+).*(?:called|that are like|known like|whose name is|which is called)\\s*((?:\\w+\\s*)+)\\s*\\??', 'gm')
const str = `one of 2 which is called Gundam Test?
Tell me the top 8 animes that are like Gundam`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}