import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d+).*(?:called|that are like|known like|whose name is|which is called)\\s*((?:\\w+\\s*)+)\\s*\\??";
final String string = "one of 2 which is called Gundam Test?\n"
+ "Tell me the top 8 animes that are like Gundam";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}