$re = '/\b(\d+).*(?:called|that are like|known like|whose name is|which is called)\s*((?:\w+\s*)+)\s*\??/m';
$str = 'one of 2 which is called Gundam Test?
Tell me the top 8 animes that are like Gundam';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);