re = /\b(\d+).*(?:called|that are like|known like|whose name is|which is called)\s*((?:\w+\s*)+)\s*\??/m
str = 'one of 2 which is called Gundam Test?
Tell me the top 8 animes that are like Gundam'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end