using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z]+?\([\-a-z0-9\s]*?\)";
string input = @"rotate(-10 50 100)
translate(-36 45.5)
skewX(40)
scale(1 0.5)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}