package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z]+?\([\-a-z0-9\s]*?\)`)
var str = `rotate(-10 50 100)
translate(-36 45.5)
skewX(40)
scale(1 0.5)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}