$re = '/[a-z]+?\([\-a-z0-9\s]*?\)/m';
$str = 'rotate(-10 50 100)
translate(-36 45.5)
skewX(40)
scale(1 0.5)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);