// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[a-z]+?\([\-a-z0-9\s]*?\)").unwrap();
let string = "rotate(-10 50 100)
translate(-36 45.5)
skewX(40)
scale(1 0.5)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}