using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{5})\s{2,}([^\d\s]+(?:\s+[^\d\s]+)*(?:\s+[a-zA-Z]{1,2}\d{1,2})?)\s+(\d+)\s+(\d+)";
string input = @"19848 Example School W8 50 14
10394 ABC School 50 34
18747 ABC School 50 14 //(18747)(ABC School)(50)(14)
17646 EFG School W11 190 44 //(17646)(EFG School W11)(190)(44)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}