# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]{5})\s{2,}([^\d\s]+(?:\s+[^\d\s]+)*(?:\s+[a-zA-Z]{1,2}\d{1,2})?)\s+(\d+)\s+(\d+)"
test_str = ("19848 Example School W8 50 14\n"
"10394 ABC School 50 34\n\n"
"18747 ABC School 50 14 //(18747)(ABC School)(50)(14)\n"
"17646 EFG School W11 190 44 //(17646)(EFG School W11)(190)(44)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.