import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{5})\\s{2,}([^\\d\\s]+(?:\\s+[^\\d\\s]+)*(?:\\s+[a-zA-Z]{1,2}\\d{1,2})?)\\s+(\\d+)\\s+(\\d+)";
final String string = "19848 Example School W8 50 14\n"
+ "10394 ABC School 50 34\n\n"
+ "18747 ABC School 50 14 //(18747)(ABC School)(50)(14)\n"
+ "17646 EFG School W11 190 44 //(17646)(EFG School W11)(190)(44)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}