import Foundation
let pattern = #"([0-9]{5})\s{2,}([^\d\s]+(?:\s+[^\d\s]+)*(?:\s+[a-zA-Z]{1,2}\d{1,2})?)\s+(\d+)\s+(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
19848 Example School W8 50 14
10394 ABC School 50 34
18747 ABC School 50 14 //(18747)(ABC School)(50)(14)
17646 EFG School W11 190 44 //(17646)(EFG School W11)(190)(44)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)