$re = '/([0-9]{5})\s{2,}([^\d\s]+(?:\s+[^\d\s]+)*(?:\s+[a-zA-Z]{1,2}\d{1,2})?)\s+(\d+)\s+(\d+)/m';
$str = '19848 Example School W8 50 14
10394 ABC School 50 34
18747 ABC School 50 14 //(18747)(ABC School)(50)(14)
17646 EFG School W11 190 44 //(17646)(EFG School W11)(190)(44)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);