import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ГОСТ\\s*\\d+\\.\\d+-\\d+";
final String string = "ГОСТ 2.301-68 ЕСКД. Форматы;о наследия (памятниках истории и \n"
+ "культуры) народов\n"
+ "ГОСТ 34.201-89. Информационная технология. Комплекс стандартов на \n"
+ "автоматизированные системы. Виды, комплектность и обозначение документов при \n"
+ "создании автоматизированных систем;\n"
+ "ГОСТ 34.003-90 Информационная технология. Комплекс стандартов на \n"
+ "автоматизированные системы. Термины и определения;\n"
+ "ГОСТ 34.601-90 Информационная технология. Комплекс стандартов на \n"
+ "автоматизированные системы. Автоматизированные системы. Стадии создания;\n"
+ "ГОСТ 34.603-92 Информационная технология. Виды испытаний автоматизированных \n"
+ "систем;РД 50-34.698-90. Методические указания. Информационная технология. \n"
+ "Комплекс стандартов на автоматизированные системы. Автоматизированные \n"
+ "системы. Требования к содержанию документов;";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}