import re
regex = re.compile(r"ГОСТ\s*\d+\.\d+-\d+", flags=re.IGNORECASE | re.UNICODE)
test_str = ("ГОСТ 2.301-68 ЕСКД. Форматы;о наследия (памятниках истории и \n"
"культуры) народов\n"
"ГОСТ 34.201-89. Информационная технология. Комплекс стандартов на \n"
"автоматизированные системы. Виды, комплектность и обозначение документов при \n"
"создании автоматизированных систем;\n"
"ГОСТ 34.003-90 Информационная технология. Комплекс стандартов на \n"
"автоматизированные системы. Термины и определения;\n"
"ГОСТ 34.601-90 Информационная технология. Комплекс стандартов на \n"
"автоматизированные системы. Автоматизированные системы. Стадии создания;\n"
"ГОСТ 34.603-92 Информационная технология. Виды испытаний автоматизированных \n"
"систем;РД 50-34.698-90. Методические указания. Информационная технология. \n"
"Комплекс стандартов на автоматизированные системы. Автоматизированные \n"
"системы. Требования к содержанию документов;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")