// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?iu)ГОСТ\s*\d+\.\d+-\d+").unwrap();
let string = "ГОСТ 2.301-68 ЕСКД. Форматы;о наследия (памятниках истории и
культуры) народов
ГОСТ 34.201-89. Информационная технология. Комплекс стандартов на
автоматизированные системы. Виды, комплектность и обозначение документов при
создании автоматизированных систем;
ГОСТ 34.003-90 Информационная технология. Комплекс стандартов на
автоматизированные системы. Термины и определения;
ГОСТ 34.601-90 Информационная технология. Комплекс стандартов на
автоматизированные системы. Автоматизированные системы. Стадии создания;
ГОСТ 34.603-92 Информационная технология. Виды испытаний автоматизированных
систем;РД 50-34.698-90. Методические указания. Информационная технология.
Комплекс стандартов на автоматизированные системы. Автоматизированные
системы. Требования к содержанию документов;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}