#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)({{(?:[1-9]|[1-9]\d)}})(?<!^(?:[^]*\1){2})"
Local $sString = "{{1}}{{2}}{{3}}{{4}}{{5}}{{1}}" & @CRLF & _
"{{11}}{{12}}{{13}}{{14}}{{12}}{{11}}" & @CRLF & _
"{{21}}{{22}}{{22}}{{24}}{{21}}{{21}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")