using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({{(?:[1-9]|[1-9]\d)}})(?<!^(?:[^]*\1){2})";
string input = @"{{1}}{{2}}{{3}}{{4}}{{5}}{{1}}
{{11}}{{12}}{{13}}{{14}}{{12}}{{11}}
{{21}}{{22}}{{22}}{{24}}{{21}}{{21}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}