import Foundation
let pattern = #"({{(?:[1-9]|[1-9]\d)}})(?<!^(?:[^]*\1){2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{{1}}{{2}}{{3}}{{4}}{{5}}{{1}}
{{11}}{{12}}{{13}}{{14}}{{12}}{{11}}
{{21}}{{22}}{{22}}{{24}}{{21}}{{21}}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)