import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{\\{(?:[1-9]|[1-9]\\d)\\}\\})(?<!^(?:[^]*\\1){2})";
final String string = "{{1}}{{2}}{{3}}{{4}}{{5}}{{1}}\n"
+ "{{11}}{{12}}{{13}}{{14}}{{12}}{{11}}\n"
+ "{{21}}{{22}}{{22}}{{24}}{{21}}{{21}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}