re = /({{(?:[1-9]|[1-9]\d)}})(?<!^(?:[^]*\1){2})/m
str = '{{1}}{{2}}{{3}}{{4}}{{5}}{{1}}
{{11}}{{12}}{{13}}{{14}}{{12}}{{11}}
{{21}}{{22}}{{22}}{{24}}{{21}}{{21}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end