using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((<b>(.*?)<\/b>)\n(<b>(.*?)<\/b>)\n(<b>(.*?)<\/b>)|(<b>(.*?)<\/b>)\n(<b>(.*?)<\/b>))|(<b>(.*?)<\/b>)";
string substitution = @"";
string input = @"<b>A</b>
<b>B</b>
<b>C</b>
<b>D</b>
<b>E</b>
<b>F</b>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}