$re = '/((<b>(.*?)<\/b>)\n(<b>(.*?)<\/b>)\n(<b>(.*?)<\/b>)|(<b>(.*?)<\/b>)\n(<b>(.*?)<\/b>))|(<b>(.*?)<\/b>)/m';
$str = '<b>A</b>
<b>B</b>
<b>C</b>
<b>D</b>
<b>E</b>
<b>F</b>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;