use strict;
my $str = '<b>A</b>
<b>B</b>
<b>C</b>
<b>D</b>
<b>E</b>
<b>F</b>';
my $regex = qr/((<b>(.*?)<\/b>)\n(<b>(.*?)<\/b>)\n(<b>(.*?)<\/b>)|(<b>(.*?)<\/b>)\n(<b>(.*?)<\/b>))|(<b>(.*?)<\/b>)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";