import Foundation
let pattern = #"((<b>(.*?)<\/b>)\n(<b>(.*?)<\/b>)\n(<b>(.*?)<\/b>)|(<b>(.*?)<\/b>)\n(<b>(.*?)<\/b>))|(<b>(.*?)<\/b>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<b>A</b>
<b>B</b>
<b>C</b>
<b>D</b>
<b>E</b>
<b>F</b>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)