import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((<b>(.*?)<\\/b>)\\n(<b>(.*?)<\\/b>)\\n(<b>(.*?)<\\/b>)|(<b>(.*?)<\\/b>)\\n(<b>(.*?)<\\/b>))|(<b>(.*?)<\\/b>)";
final String string = "<b>A</b>\n"
+ "<b>B</b>\n"
+ "<b>C</b>\n\n"
+ "<b>D</b>\n"
+ "<b>E</b>\n\n"
+ "<b>F</b>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}