using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"What is your vendor location\?:\s*(.+)";
string input = @"Your full name (TL submitting form): XXX
What is your vendor location?: Phoenix";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}