// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)What is your vendor location\?:\s*(.+)").unwrap();
let string = "Your full name (TL submitting form): XXX
What is your vendor location?: Phoenix";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}