$re = '/What is your vendor location\?:\s*(.+)/m';
$str = 'Your full name (TL submitting form): XXX
What is your vendor location?: Phoenix';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);