# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\p{Sc})[0,]+(?=\d)//gm;t' <<< "$123,456.78
$0012,345.67
$123,04.56
$123,45.06
$0.1
$0,000.1"