import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\p{Sc})[0,]+(?=\\d)";
final String string = "$123,456.78\n"
+ "$0012,345.67\n"
+ "$123,04.56\n"
+ "$123,45.06\n"
+ "$0.1\n"
+ "$0,000.1";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}