import Foundation
let pattern = #"(?<=\p{Sc})[0,]+(?=\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$123,456.78
$0012,345.67
$123,04.56
$123,45.06
$0.1
$0,000.1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)