# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\p{Sc})[0,]+(?=\d)"
test_str = ("$123,456.78\n"
"$0012,345.67\n"
"$123,04.56\n"
"$123,45.06\n"
"$0.1\n"
"$0,000.1")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.