re = /(?<=\p{Sc})[0,]+(?=\d)/m
str = '$123,456.78
$0012,345.67
$123,04.56
$123,45.06
$0.1
$0,000.1'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result