import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".";
final String string = "Lorem ipsúm dolor sit amet, sóleat coñsetetur et nam, vocibus convenire an vis. ¿Nostrum mediócritatem hís cu? Lobortis vítuperata has ñe. ¡Vis ex mágna summo coñsequat, mándamus mediocrem repudiare ut méa, ne eám sempér melius! ¿Ullúm debitis ut duo? Cu vídit sigñiferúmque vel, quo ex simul facilís, mea ridens maiorum ad.\n\n"
+ "Unum vero at his. Numquam habemús medíocrem pri et, pró erroribús incorrupte ad, debet menandri incidérint eos at. Mazim ígnota cu mel, elit facilis at nec. Pro ea libris numquám, ñullám veritus accommodaré eú eos.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}