// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".").unwrap();
let string = "Lorem ipsúm dolor sit amet, sóleat coñsetetur et nam, vocibus convenire an vis. ¿Nostrum mediócritatem hís cu? Lobortis vítuperata has ñe. ¡Vis ex mágna summo coñsequat, mándamus mediocrem repudiare ut méa, ne eám sempér melius! ¿Ullúm debitis ut duo? Cu vídit sigñiferúmque vel, quo ex simul facilís, mea ridens maiorum ad.
Unum vero at his. Numquam habemús medíocrem pri et, pró erroribús incorrupte ad, debet menandri incidérint eos at. Mazim ígnota cu mel, elit facilis at nec. Pro ea libris numquám, ñullám veritus accommodaré eú eos.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}