const regex = /./;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.', '')
const str = `Lorem ipsúm dolor sit amet, sóleat coñsetetur et nam, vocibus convenire an vis. ¿Nostrum mediócritatem hís cu? Lobortis vítuperata has ñe. ¡Vis ex mágna summo coñsequat, mándamus mediocrem repudiare ut méa, ne eám sempér melius! ¿Ullúm debitis ut duo? Cu vídit sigñiferúmque vel, quo ex simul facilís, mea ridens maiorum ad.
Unum vero at his. Numquam habemús medíocrem pri et, pró erroribús incorrupte ad, debet menandri incidérint eos at. Mazim ígnota cu mel, elit facilis at nec. Pro ea libris numquám, ñullám veritus accommodaré eú eos.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}